Презентация на тему: Бағдарламалау

Бағдарламалау
Бағдарламалау
Бағдарламалау
Бағдарламалау
Бағдарламалау
БТ түрлері
Бағдарламалау
Бағдарламалау
Бағдарламалау
Алгоритм
Алгоритм
Алгоритмнің қасиеттері
Бағдарламалау
Бағдарламалау
Бағдарламалау
Бағдарламалау
Бағдарламалау
Алгоритмнің берілу тәсілдері
Табиғи тілдегі алгоритм
Собери урожай.
Графикалық тілдегі алгоритм
Бағдарламалау
Бағдарламалау
Бағдарламалау
Алгоритмдік тіл ( псевдотіл )
Бағдарламалау
Бағдарламалау
1С программирование
Бағдарламалау тілі
площадь треугольника
Алгоритмдердің түрлері
Сызықты алгоритм
Тармақталган алгоритм
Циклдік алгоритм
Бағдарламалау
1/35
Средняя оценка: 4.5/5 (всего оценок: 95)
Код скопирован в буфер обмена
Скачать (1064 Кб)
1

Первый слайд презентации

Бағдарламалау

Изображение слайда
2

Слайд 2

Бағдарламалаудың мақсаты – компьютерді басқаратын әр түрлі ақпараттық есептерді шешетін бағдарламаларды құру Бағдарламалық камтамасыздандыру Жүйелік Қолданбалы

Изображение слайда
3

Слайд 3

Системное программиро-вание – разработка системного программного обеспечения: операционных систем, утилит и т.д. Прикладное программи-рование – создание прик-ладных программ: редак-торы, табличные процессо-ры, игры, обучающие прог-раммы и т.д.

Изображение слайда
4

Слайд 4

Бағдарламаларды құру үшін әр түрлі бағдарламалау тілдері қолданылады.

Изображение слайда
5

Слайд 5

Бағдарламалау тілі деп алгоритмдерді және деректер құрылымын сипаттауға арналған жасанды тіл. Кез келген тіл сияқты ол символдар жиынтығынан ( алфавит ), алгоритмдік тілдерді жазу ережелерінен ( синтаксис ) және жазуларды түсіндіру мәтіндерінен ( семантика ) тұрады.

Изображение слайда
6

Слайд 6: БТ түрлері

Төменгі деңгейлі тілдер – мұнда бағдарлама берілген ЭЕМге арналған аппараттық (машиналық) деңгейде жазылған командалардан тұрады. Мысалы: Машиналық тіл, Ассемблер, Макроассемблер Жоғарғы деңгейлі тілдер – мұнда бағдарлама кез келген ЭЕМге арналған және бағдаламалау тілі адам тіліне жақын. Мысалы: ForTran, Basic, Pascal, C, C++, C#, Java

Изображение слайда
7

Слайд 7

Бағдарламалау жүйесі бұл белгілі бір бағдарламалау тілінде жазылған бағдарламаларды құру ға, түзетуге және іске қосуға арналған компьютерлік БҚ

Изображение слайда
8

Слайд 8

Разработка любой программы начинается с построения алгоритма решения задач. Такие алгоритмы называют алгоритмами работы с величинами. В качестве исполнителя рассматривается – компьютер, оснащенный системой программирова-ния на определенном языке. Компьютер-исполнитель работает с определенными данными по определенной программе.

Изображение слайда
9

Слайд 9

Бағдарлама – енгізілген берілгендерді өңдеу үшін арнайы және қатаң түрде қандай да бір бағдарламалаутілінде дайындалған алгоритм. Кез-келген алгоритм қандай да бір орындаушыға негізделген. Орындалған командалар жиынтығы орындаушының командалар жүйесі болып табылады. Орындаушы ретінде – адамдар және техникалық құрылғылар, яғни роботтар, компьютерлер және автоматтар болуы мүмкін.

Изображение слайда
10

Слайд 10: Алгоритм

Изображение слайда
11

Слайд 11: Алгоритм

Алгоритм,  алгорифм  ( ағылшынша : algor і thm, algor і smus —  Әл-Хорезмидің  атынан шыққан) Алгоритм бастапқы берілген мәліметтермен бір мәнде анықталатын нәтиже алу үшін қай амалды қандай ретпен орындау қажеттігін белгілейтін есептерді шешу тәсілдерінің дәл сипаттамасы. Агоритмді орындау  алгоритмдік процесс  деп аталады.

Изображение слайда
12

Слайд 12: Алгоритмнің қасиеттері

Изображение слайда
13

Слайд 13

Алгоритм обладает следующими свойствами: 1. Дискретность. Это свойство состоит в том, что алгоритм должен представлять процесс решения задачи как последовательное выполнение простых шагов. При этом для выполнения каждого шага алгоритма требуется конечный отрезок времени, т.е. преобразование исходных данных в результат осуществляется во времени дискретно. 2. Определенность. Каждое правило алгоритма должно быть четким, однозначным. 3. Результативность. Алгоритм должен приводить к решению за конечное число шагов. 4. Массовость. Алгоритм решения задачи разрабатывается в общем виде, т.е. он должен быть применим для некоторого класса задач, различающихся лишь исходными данными. 5. Правильность. Алгоритм правильный, если его выполнение дает правильные результаты решения поставленной задачи.

Изображение слайда
14

Слайд 14

1.Алгоритмнің дискреттігі ( үздіктілігі) – ақпаратты өңдеу процесі ретімен жазылған, аяқталған нұсқаулардан құралған тізбектерден тұруы тиіс, яғни орындаушының келесі қадамға өтуі алдыңғы қадамның аяқталуынан кейін жүзеге асуы керек; 2.Алгоритмнің түсініктілігі – алгоритмді құру барысында оның орындаушыға түсінікті болатындығы ескерілуі керек;

Изображение слайда
15

Слайд 15

3.Алгоритмнің анықтылығы – алгоритм жалпы түрде қабылданған символдарды, алфавитті пайдаланып жазылуы тиіс. Орындаушы (адам, компьютер) алгоритмді түсініп, орындай алатын болуы керек. Оның үстіне түрліше түсінілетін нұсқаулар енгізілмеуі тиіс. Ол орындаушыға алгоритмді орындау үшін басқа нұсқаулар іздеуіне жол қалдырмайтындай етіліп және орындалу реттері дәл көрсетіліп қатаң түрде жазылуы қажет.

Изображение слайда
16

Слайд 16

4.Алгоритмнің көпшілікке бірдейлігі – қарастырылып отырған ақпараттың кез-келген мәндерінде нақты бір ғана тапсырманы емес, соған типтес бүкіл тапсырманы шеше білуі. Мысалы, квадрат теңдеуді шешу алгоритмі – коэффиценттің кез-келген мәнінде оның түбірін табуға мүмкіндік береді немесе жолда жүру ережесі барлығымызға бірдей.

Изображение слайда
17

Слайд 17

5.Алгоритмнің нәтижелілігі. Нұсқаулар шексіз көп болмай, қорытындысында оның нәтижесі болуы тиіс. Егер алгоритм бойынша құрылған сандық программа шексіз есептеулерге әкелсе, онда алгоритмнің талапқа сай жазылмағаны не есептің шешуі жоқ болғаны.

Изображение слайда
18

Слайд 18: Алгоритмнің берілу тәсілдері

Изображение слайда
19

Слайд 19: Табиғи тілдегі алгоритм

орындаушысы адам, қажетті құрал-жабдықтары – қазақ, орыс және ағылшын алфавиті; Начало. Достань хлеб,масло,сыр,нож. Возьми нож. Отрежь кусок хлеба. Отрежь ломтик сыра. Намажь кусок хлеба маслом. Положи на масло ломтик сыра. Убери на место хлеб,масло,сыр,нож. Конец.

Изображение слайда
20

Слайд 20: Собери урожай

Начало. Войди в сад. Подойди к яблоне. Сорви яблоко. Положи яблоко в корзину. Остались яблоки на яблоне. Конец.

Изображение слайда
21

Слайд 21: Графикалық тілдегі алгоритм

– орындаушысы адам, қажетті құрал-жабдықтары – әрбір әрекеті түрлі жазықтықтағы геометриялық фигура ретінде бейнеленіп, олардың арасындағы байланыстар түзу сызықтар мен бағыттаушылар арқылы көрсетіледі;

Изображение слайда
22

Слайд 22

Изображение слайда
23

Слайд 23

Овал – алгоритмнің басы не соңы екенін білдіреді; қажеттісі ішіне жазылады. Төртбұрыш – ақпаратты өңдеу процесі

Изображение слайда
24

Слайд 24

Ромб - кейбір айнымалылардың, шарттардың орындалуына байланысты алгоритмнің бағытын таңдау процесі қосалқы алгоритм Параллелограмм -берілгендерді ендіру және нәтижені шығару

Изображение слайда
25

Слайд 25: Алгоритмдік тіл ( псевдотіл )

орындаушысы адам, қажетті құрал-жабдықтары – жаратылыстану тіліндегі қандай да бір мағынаны, бұйрықты білдіретін сөздер жиынтығы;

Изображение слайда
26

Слайд 26

алг, арг, нәт алгоритм тақырыбы басы, соңы алгоритмнің басталуы мен соңы егер-онда-әйтпесе-бітті тармақталу командасы таңдау, жағдай...жағдай-әйтпесе-бітті таңдау командасы n рет циклі: n рет қайталау командасы «Әзірше» циклі: цб (цикл басы), әзір (әзірше), цс (цикл соңы) «Үшін» циклі: цб, үшін, дан (-ден, -тан, -тен, -нан, -нен) немесе бастап, дейін, қадам, келесі, цс және, немесе, емес құрама шарттар мән; -өту n; -егер Р өту n (Р-шарт) функция (айнымалы), мұндағы өту n және егер Р өту n - басқарушы операторлар. Өту n сөзсіз (шартсыз) өту операторы, алгоритм командаларының орындалу ретін тоқтатып, келесі орындалуды n-жолға беру жөніндегі нұсқау.

Изображение слайда
27

Слайд 27

алг  ЗДРАВСТВУЙМИР нач вывод ('Здравствуй, Мир!') кон   алг  ЗДРАВСТВУЙМИР

Изображение слайда
28

Слайд 28: 1С программирование

Функция ОстатокТовара (Товар, ДатаПо, Магазин, ТекДок) Экспорт Запрос = СоздатьОбъект ("Запрос"); ТекстЗапроса = "//{{ЗАПРОС |Период с {Константа. ДатаУчетаОстатков} по {ДатаПо}; |ОбрабатыватьДокументы Все; |Наименование = Документ. ПриходТовара. Наименование; |Склад = Документ. ПриходТовара. Магазин; |Кол = Документ. ПриходТовара. Кол; |Группировка документ; |Функция Остаток = Сумма (Кол) ; |Условие (Склад=Магазин) ; |Условие (Наименование=Товар) ; |";//}}ЗАПРОС док = СоздатьОбъект ("Документ. КассовыйЧек"); док. ВыбратьДокументы (ДатаПо, ДатаПо) ; Расход = 0; Пока док. ПолучитьДокумент ()=1 Цикл Если (док. Магазин=Магазин) и (док. ТекущийДокумент ()<>ТекДок) Тогда док. ВыбратьСтроки (); Пока док. ПолучитьСтроку ()=1 Цикл Если СокрЛП (док. БарКод) =СокрЛП (Товар. Код) Тогда Расход = Расход + док. Кол; КонецЕсли; КонецЦикла; КонецЕсли; КонецЦикла; Если Запрос. Выполнить (ТекстЗапроса) =0 Тогда Сообщить ("Произошла ошибка при выборке остатков, повторите ввод кол-ва! ", "!"); Возврат 0; КонецЕсли; Приход = 0; Пока Запрос. Группировка (1)=1 Цикл Приход = Приход + Запрос. Остаток; КонецЦикла; Возврат Приход - Расход; КонецФункции

Изображение слайда
29

Слайд 29: Бағдарламалау тілі

орындаушысы компьютер, қажетті құрал-жабдықтары – арнаулы бағдарламалаутілінің командалары.

Изображение слайда
30

Слайд 30: площадь треугольника

program pl; var a,h,s:real; begin cls; write(' Введите основание и высоту труеглольника '); readln(a,h); S:=a/2*h; write(' площадь треугольника равна ', S); end. int a, b, A; double S; a = i nt.Parse(Console.ReadLine()); b = int.Parse(Console.ReadLine()); A = int.Parse(Console.ReadLine()); S = a * b * Math.Sin(3.1415 / A) / 2; Console.WriteLine(S); Console.ReadKey();

Изображение слайда
31

Слайд 31: Алгоритмдердің түрлері

Изображение слайда
32

Слайд 32: Сызықты алгоритм

Егер орындаушы командаларды бірінен соң бірін ілесу төртібімен орындайтын болса, алгоритм сызықты деп аталады.

Изображение слайда
33

Слайд 33: Тармақталган алгоритм

Орындаушының өрекеттері кейбір шарттарды тексеру нәтижелерімен белгіленетін болса, ол алгоритм тармақталган болып саналады. Басы Х енгізу Соңы х  0 иә жоқ у = х 2 Нәтиже у

Изображение слайда
34

Слайд 34: Циклдік алгоритм

Жеке командалар немесе команда топтары көп рет қайталанатын болса, алгоритм циклдік деп саналады.

Изображение слайда
35

Последний слайд презентации: Бағдарламалау

Изображение слайда